La Funzione SE in Excel

Tra le moltissime funzioni di Excel la SE rappresenta una delle più utilizzate in quanto permette di operare una discrezionalità su un certo tipo di risultato. Fa parte delle funzioni cosidette “Condizionali” in quanto restituisce un risultato in base ad una condizione che noi impostiamo.

Vediamo la sua struttura:

SE(test da effettuare;operazione da fare per risultato test VERO;operazione da fare per risultato test FALSO)

La funzione SE si basa su 3 parametri (vi ricordo che in tutte le funzioni di Excel i parametri si separano tramite il punto e virgola ;)

Il primo parametro della funzione SE è il test che vogliamo effettuare.
Nel nostro caso vogliamo, ad esempio, confrontare il valore contenuto nella cella C1 con quello della cella cella D1 e sapere se C1 è maggiore di D1 (C1>D1)

Il secondo parametro è l’operazione che vogliamo compiere se il risultato del test è VERO.

Il terzo parametro è l’operazione che vogliamo compiere se il risultato del test è FALSO.

Funzione SE Excel

Poniamo ad esempio che in C1 sia riportato il valore 1000 e che in D1 ci sia il valore 880, quindi C1 è maggiore di D1? Si, cioè è VERO che C1 è maggiore di D1. Poichè il test che ho eseguito mi restituisce un valore VERO allora voglio eseguire una certa operazione (ad esempio C1+20).
Questa operazione la devo inserire al posto del secondo parametro della funzione.

Se invece avessi avuto valori diversi contenuti nelle celle C1 e D1, ad esempio in C1 ho il valore 880 e in D1 il valore 1000 allora il test mi avrebbe restituito FALSO in quanto C1 NON è maggiore di D1. In questo caso allora voglio compiere quest’altra operazione D1+30.
Questa operazione andrà invece inserita nel terzo parametro.

Quindi alla fine la nostra funzione si scrive:

=SE(C1>D1;C1+20;D1+30)

Excel Funzione SE

e si legge in questo modo:

SE C1 è maggiore di D1 allora esegui l’operazione C1+20 altrimenti esegui l’operazione D1+30

SE Funzione Excel

Facciamo adesso un esempio più reale dell'applicazione della funzione SE di Excel.
Poniamo di dover valutare dei candidati che hanno sostenuto delle prove per essere ammessi ad un certo corso. Il nostro obiettivo è quello di sapere se, dalla media dei voti riportati, il candidato è ammesso o non ammesso al corso. Impostiamo in un foglio di calcolo una tabella in cui andremo a riportate i nominativi dei candidati e il punteggio ottenuto in ciascuna prova.

Esempio funzione SE Excel

Calcoliamo infine nella colonna G la media dei punteggi riportati in ciascuna prova. A questo punto vogliamo mostrare nella colonna H il risultato della valutazione.

La funzione SE che andremo ad inserire nelle celle della colonna H sarà pertanto:

=SE(G2>6;"Ammesso";"Non Ammesso")

che tradotta si può leggere: SE la media dei punteggi riportati nelle prove calcolato nella cella G2 è maggiore di 6 allora il candidato è Ammesso altrimenti è Non Ammesso

Potete scaricare il file di Excel con l'esempio completo facendo clic qui.

Argomenti correlati:

Funzione SE con più condizioni (nidificata)

link sponsorizzati