La Funzione SE con più condizioni (nidificata)

In un precedente articolo abbiamo visto come impostare la funzione SE di Excel e abbiamo fatto alcuni semplici esempi di utilizzo (fai clic qui per leggerlo).

Nell'ultimo esempio fatto abbiamo ipotizzato di valutare alcuni candidati che hanno sostenuto delle prove per essere ammessi ad un corso. Il nostro obiettivo è quello di sapere se, dalla media dei voti riportati, il candidato è ammesso o non ammesso al corso. Abbiamo pertanto impostato in un foglio di calcolo una tabella in cui abbiamo riportato i nominativi dei candidati e il punteggio ottenuto in ciascuna prova.

Funzione SE nidificata Excel

Abbiamo infine calcolato nella colonna G la media dei punteggi riportati in ciascuna prova e, tramite la funzione SE, abbiamo mostrato nella colonna H il risultato della valutazione.

=SE(G2>6;"Ammesso";"Non Ammesso")

Come possiamo vedere dall'immagine abbiamo pertanto 3 candidati Ammessi e 1 candidato Non ammesso.

Adesso vogliamo apportare un'ulteriore miglioramento a questa tabella. Poichè ci possono essere candidati maschi e candidati femmine vogliamo usare il termine più corretto per segnalare l'ammmissione o meno al corso. In altre parole vogliomo che nella colonna relativa al risultato compaia "Ammesso" (o "Non ammesso") per i candidati maschi e "Ammessa" (o "Non ammessa") per quelli di sesso femminile.

Si tratta quindi di operare un ulteriore test all'interno di un test già definito (la prima funzione SE).

La funzione SE di Excel è infatti nidificabile ossia si possono eseguire più funzioni SE combinate tra loro rispettando ovviamente l'ordine dei parametri.

Per eseguire questo ulteriore test (Maschio o Femmina) dobbiamo introdurre una nuova colonna nella nostra tabella dove indicheremo il sesso dei nostri candidati.

Funzione SE excel più condizioni

A questo punto possiamo modificare la funzione inserita nelle celle della colonna I

=SE(H2>6;"Ammesso";"Non Ammesso")

con la seguente:

=SE(H2>6;SE(B2="M";"Ammesso";"Ammessa");SE(B2="M";"Non Ammesso";"Non Ammessa"))

Come possiamo vedere abbiamo introdotto al posto dei risultati del primo test (H2>6) un ulteriore test rappresentato da una nuova funzione SE

SE(B2="M";"Ammesso";"Ammessa")

per mezzo della quale valutiamo se il contenuto della cella B2 contiene "M" (Maschio) o no.

Funzione SE con più condizioni

e restituiamo la giusta dicitura, al maschile o al femminile, in base al genere del candidato.

Una considerazione finale, è possibile nidificare quante volte vogliamo una funzione dentro l'altra ma cerchiamo di superare il limite massimo di 1024 caratteri di lunghezza della funzione completa. Al di la della complessità di gestire funzioni così lunghe le versioni di Excel precedenti alla 2007 (quindi Excel 2003, Excel XP o 2002, Excel 2000 e Excel 97) non gestiscono più di questo numero di caratteri per cella. Quindi nel caso dobbiamo usare un foglio di calcolo (o trasmetterlo ad un'altra persona) non conoscendo esattamente la versione di Excel che sarà utilizzata è bene non superare tale limite pena il mancato funzionamento del foglio di calcolo stesso.

Potete scaricare il file di Excel con l'esempio completo facendo clic qui.

Argomenti correlati:

Funzione SE esempi

link sponsorizzati
Se ti è piaciuto questo articolo condividilo sul tuo social preferito